Overview:
The Call_Channel_Formula_vod field is configured within the org, and the Call_Channel_vod and Call_Channel_Formula_vod fields are not present on the Page Layout. Despite this, the Call Channel picklist still appears when the user creates a Call in CRM offline.
Root Cause:
This issue can occur when the user does not have proper Field Level Security (FLS) to the Call_Channel_Formula_vod field.
Solution:
- Grant the user Read FLS to the Call_Channel_Formula_vod field on the Call2_vod object
- Ensure the user has at least Read FLS to all fields mentioned in the Call_Channel_Formula_vod field
- Be sure the user has Edit FLS to the field in Call_Channel_Formula_vod present on the user's Page Layout(s)
Related Documentation:
CRM Help Documentation: Auto-Populating the Call Channel