Overview:
The user uses the Sum expression to count how many records are in a Record List, but the Sum expression does not work when counting the number of records by ID in MyInsights Studio of CRM.
There is no ID in the field of the Record List:
Root Cause:
This is working as designed.
The Sum expression is intended to add up a collection of number fields - not to count a collection of unique IDs. Thus, it only allows the user to select number fields. If the Data Element does not have any number fields, the list of available fields is empty.
Solution:
If the user wants to count how many records are in the Record List, the expression to use is Count Unique instead of Sum. The Count Unique expression counts up the number of unique items in a list. It can do this for any type of field except for boolean fields. If using Count Unique, the ID field would show up in the list of available fields. Because each record ID is unique, counting the number of unique IDs is equivalent to counting the number of records.
Related Documentation:
CRM Help Documentation: Adding Data for MyInsights Pages
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