Overview:
The Add Attachment button is not available on the Attachments related list when accessing a speaker from the Speaker Tab:
Root Cause:
The user is missing OLS Edit permission on the EM_Speaker_vod object.
Solution:
- Grant the user OLS Edit permission on the EM_Speaker_vod object
- Clear the Veeva cache
- Perform a sync
Related Documentation:
CRM Help Documentation: Speaker Tab