Overview:
When logging into the Vault with a cross-domain user account, the following error message appears:
"Vault not available.
You do not have access to an active Vault. Please contact your administrator for assistance."
Root Cause:
The home domain user is made Inactive. In other words, the cross-domain users are created based on the user account in the home domain, so if the original user account is inactive, users cannot log into Vault with the cross-domain user account.
Solution:
Activate the original user account in the home domain.
Related Documentation:
Vault Help Documentation: Cross-Domain Users & Authentication