Overview:
A user associated with custom roles has both Open and Answer query permissions. But, the user cannot change an open Query to Answered status even when after replying to the Query. Why is the user with Answer permission unable to change an open Query to Answered status?
Root Cause:
If a user has both Open and Answer query permissions, the query stays Open status instead of Answered even after the user replying to the Query.
Solution:
The user (usually, the Site user) who has only Answer query permission can change an open Query to Answered status after replying to the Query.
Related Documentation:
Vault Help Documentation: How to Answer a Query