Overview:
Vault sends a user an email with the results of the Run in Preview Mode job and the warning message Failed to delete appears while attempting to delete forms due to a Rule in the rule_details file.
Root Cause:
The message does not indicate an "error" but is letting the user know that the form instance will not automatically delete by the rule until the form is in a state that can be deleted.
Solution:
The form will only delete if all of the below are true:
- The form's InstanceStatus is Blank
- The form is not locked or frozen
- None of the form's items are locked or frozen
Related Documentation:
Vault CDMS Rules Documentation: Running Rules