Overview:
When clicking on the New Event Speaker button from the Event detail page, the following screen is hanging and will never load the available Speakers.
Root Cause:
The user is missing FLS access to the Topic_vod__c field on the EM_Event_vod__c object.
Solution:
Grant at least read FLS to the Topic_vod__c field on the EM_Event_vod__c object on the user's profile or via a Permission Set. Clear the Veeva Cache afterward.
Related Documentation:
CRM Help Documentation: Speaker Management