Overview:
An error occurs when Opening WeChat CRM Home Page.
Error: error=redirect_uri_mismatch&error_description=redirect_uri must match configuration
Root Cause:
One possible reason is the Callback URL is not configured correctly in the Connected App.
Solution:
Configure the Callback URL as below:
- Navigate to Setup -> App Setup -> Create -> Apps
- Find WeChat CRM App and click the Edit button
- Populate the Callback URL as below:
Sandbox -
https://wcrm-36-sbx-app-ap.veevacrm.cn/wechat-crmapp/_auth
https://wcrm-36-sbx-app-ap.veevacrm.cn/crm-service/_auth
https://wcrm-36-sbx-app-ap.veevacrm.cn/qyaw-service/_authProduction -
https://wcrm-36-app-ap.veevacrm.cn/wechat-crmapp/_auth
https://wcrm-36-app-ap.veevacrm.cn/crm-service/_auth
https://wcrm-36-app-ap.veevacrm.cn/qyaw-service/_auth - Clear WeChat CRM Cache
Related Documentation:
CRM Help Documentation: Salesforce and CRM Setup
Send us your feedback: We're always looking for feedback to help improve our Knowledge Base! Please let us know if this article was helpful or provide feedback on how we can improve your experience here.