0

Veeva Engage Requiring TLS 1.2

To align with industry best practices for security and data integrity, Veeva Engage will require TLS 1.2 or higher for all connections beginning April 27. HCPs connecting to Veeva Engage using TLS 1.1 encryption or earlier will not be accepted. This update affects less than 1% of HCPs who are using Internet Explorer 8, 9, or 10, which will no longer be supported after this date.

 

Comments not allowed