概要:
用户发现有一些组织中的客户并没有从上级客户继承地址。在CRM Online上,地址继承并没有创建或更新地址记录。
根本原因:
对于地址继承,当批处理运行时,下面两个主要条件必须要满足:
- Copy Address在下级客户的记录上被启用(选中)
- Last Address Run自定义设置的日期时间一定要早于上级地址的Last Modified By的值
当地址继承批处理运行时,会进行如下的操作:
- 更新上级地址的Last Modified By字段
- 复制新的地址到继承的客户
- 更新既存的下级记录
解决方案:
使用系统管理员来从Developer Console直接运行作业:
- 从页面的右上角访问用户名称
- 访问:Developer Console --> Debug
- 打开Execute Anonymous窗口
- 粘贴负责地址继承的Apex Class (EXAMPLE_FOR_ADDRESS_PUSH_SCHEDULING)的代码:
代码:
VEEVA_BATCH_CHILD_ACCOUNT_PUSH b = new VEEVA_BATCH_CHILD_ACCOUNT_PUSH();
database.executebatch(b,10);
VEEVA_BATCH_CHILD_ACCOUNT_DELETE c = new VEEVA_BATCH_CHILD_ACCOUNT_DELETE();
database.executebatch(c,25);
- 检查设置 --> Apex 作业看它们是否完成
- 在Developer Console中,批处理会产生包含详细信息的额外日志
- 从计划的作业中计划相关的Apex 类
关联文档:
- CRM知识库文章: Address Inheritance Does Not Copy Address
- CRM在线帮助文档: Address Inheritance Support
请告诉我们您的反馈:我们始终期待您的反馈来帮助我们提升知识库!请让我们知道这篇文章是否有帮助。您可以通过点击这里告诉我们。