概要:
通过数据导入方式导入到CRM中的客户区域加载器(Account Territory Loader - ATL)记录不能正常工作。客户共享(AccountShare)记录在数据导入作业完成后不能被相应的插入或者更新。
根本原因:
由于批量导入数据时的数据量过大而导致ATL记录不会被更新。
如果批量导入时设置的批量导入大小(batch size)超过20那么触发器(trigger)会从ATL字段中拷贝区域(territory)信息并导致客户共享(AccountShare)记录不会被更新。这是因为已达到了Salesforce的查询限制。
解决方案:
将批量大小(batch size)的值设置小一些。该值的最佳区间约为10-20。
关联文档:
CRM在线帮助文档: Territory Assignment
Salesforce在线帮助文档:Execution Governors And Limits
请告诉我们您的反馈:我们始终期待您的反馈来帮助我们提升知识库!请让我们知道这篇文章是否有帮助。您可以通过点击这里告诉我们。