概要:
当在CRM中更新地址名称时遇到了错误:
无法更新地址。
根本原因:
有两个原因可能造成这一现象:
- 该地址记录被锁定并且用户不是系统管理员
- 该地址记录是一个受控地址记录
解决方案:
对于被锁定的地址记录:
- 如果地址记录的锁定字段被设置成了true,那么只有拥有修改所有数据权限的用户才能够编辑地址记录的Address Line1(名称)字段或者删除该记录
- 如果该锁定字段为空,false或者不存在,那么触发器不会执行任何操作。锁定字段最好不要放到针对CRM for iPad应用使用的页面布局上。
- 用来阻止用户编辑地址记录的触发器是VOD_ADDRESS_VOD_BEFORE。Veeva技术支持不建议用户更改该触发器因为作为Veeva开箱即用的触发器,该触发器在将来有可能被覆盖。
注意:这里修改所有数据权限是指在用户简档的管理权限区块下的修改所有数据选项而不是针对地址对象的修改全部权限。如果该用户是一位在尝试使用Dataloader或者其他工具更新地址记录的集成用户那么该用户也会遇到同样的错误。
对于受控地址记录:
- 通过更改控制地址记录来更改受控地址或者将受控地址的控制地址信息删除从而解除控制关系只更改目标地址。
关联文档:
CRM在线帮助文档: Address Inheritance Support
请告诉我们您的反馈:我们始终期待您的反馈来帮助我们提升知识库!请让我们知道这篇文章是否有帮助。您可以通过点击这里告诉我们。