Overview:
Attendees are not syncing to Concur from CRM. The expense is created in Concur with no Attendees.
The Sync Logs from the Concur Admin contain an Error in the AttendeesPostException section:
- The Report Owner is different than the Attendee Owner. When the <SystemOwner> element is set to No, the existing Attendee Owner must be the same user as the Report Owner in order to update the attendee.
Root Cause:
For the AttendeesPostStatusCode for the Call:
- 400 is Bad Request and no Attendees are be posted.
- 200 means the request was received successfully and Attendees are be posted.
- 0 means the request was not received. There could be an issue with the Expense portion that needs to get resolved before it will sent the attendees.
The Attendees on the Call in CRM already exist in Concur but are not owned by the user who enters the expense.
A common cause is that another user enters the Attendees from the Other Attendees section. Attendees added from the Other Attendees section are saved in Concur with ExternalId = Account_vod__r.Id-FirstNameLastName.
- Account_vod__r.Id is the primary Account from the Expense Call
- The FirstNameLastName are the manual fields entered in the Other Attendee section of the Call.
Solution:
The Attendees can be manually added to the expense in Concur.
If the Attendees are added to Calls on a regular basis, they can be entered in CRM as Accounts to be selected in the Attendees Section.
Related Documentation:
CONCUR Developer Center: POST Expense Entry Attendees