Overview:
The sync in the Engage Metadata Sync Administration Console fails due to the following error:
"Failed to upsert [number] records into SF DB, status code: DUPLICATE_VALUE for Record with External Id: [value in VExternal_Id_vod__c], Cause: duplicate value found: Presentation_Id_vod__c duplicates value on record with id: [SFDC Id]."
Root Cause:
The Presentation_Id_vod__c field on the Multichannel_Content_vod__c object is unique. The sync fails if there are any Multichannel_Content_vod__c records in the CRM org where the Presentation_Id_vod field has the same value as the crm_presentation_id__v field of the new Multichannel Presentation in Vault, which the integration is trying to sync with CRM.
Solution:
There are alternative solutions to fix the issue:
- Delete the referenced Multichannel Content records if they are obsolete (Example: If the source Vault is no longer linked to the CRM org)
- Clear the Presentation_Id_vod__c field on the referenced Multichannel Content records
- Change the value in the crm_presentation_id__v field of the Multichannel Presentation in Vault
Related Documentation:
CRM Help Documentation: N/A