Overview:
When users upload PDF files that include Password Security/Adobe e-signature to Vault, some files can be rendered successfully but some of them failed to rendition. Why does this happen?
Root Cause:
One possible reason is the encryption level for these documents is different.
By default, PDF files that include Adobe® Acrobat® security settings may prevent viewing of the files in Vault inline viewer. Vault has a variety of libraries used for parsing and displaying documents in the Doc Viewer. Whether or not these libraries are able to correctly interpret locked PDFs depends largely on the encryption and the security settings. For example, 128-bit encryption is more supported by the libraries than 256-bit encryption, and some security settings can prevent specific libraries from working like text extraction may not work with content copying restricted.
Solution:
Admin can enable handling of these PDF files by selecting the "Allow viewing and annotation of protected PDF files" setting in Admin --> Configuration --> Rendition Profiles --> Default.
Related Documentation:
Vault Help Documentation: Secured PDF Files