Overview:
An Analytics File is not automatically processed and a CTL file is not removed from the Ctlfile directory.
Root Cause:
There are several possible root causes for CTL files failing to automatically process the Analytics file and disappear.
The CTL Filename must not contain any spaces. For example, the name Weekly TRx Auto Process.ctl would fail. Replace any spaces with underscores. Correct: Weekly_TRx_Auto_Process.ctl
The CTL file values are case sensitive and must match the Analytics File name exactly.
Example, the following CTL File fails for Analytics File Weekly_TRx.zip:
- USER=vodadmin@customer.com
- PASSWORD=password
- DATA_DATE=01/01/2000
- MARKET=Market
- DATA_MAP_TEMPLATE=TRx Template
- MOVE_TO_PRODUCTION=True
- FILENAME=Weekly_TRx.zip
Solution:
- Update the CTL file with the correct content and name. reupload the Analytics Data file and CTL file.
- Reupload the Analytics Data file and CTL file.
Related Documentation:
CRM Help Documentation: Automated Sales Data File Processing
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