Overview:
An Analytics File is not automatically processed and a CTL file is not removed from the Ctlfile directory.
Root Cause:
There are several possible root causes for CTL files failing to automatically process the Analytics file and disappear.
- The CTL Filename must not contain any spaces.
Example:
The name: Weekly TRx Auto Process.ctl fails. Replace any spaces with underscores.
Corrected name: Weekly_TRx_Auto_Process.ctl
-
The CTL file values are case sensitive and must match the Analytics File name exactly.
Example, the following CTL File fails for Analytics File Weekly_TRx.zip:
- The FTP Server may not be correct. The FTP Host server info is found in Veeva Common Settings.
Navigate to: Setup --> Develop --> Custom Settings --> Manage (Veeva Common) --> Main --> FTP Server
Solution:
- Update the CTL file with the correct content and name. Re-upload the Analytics Data file and CTL file.
- Re-upload the Analytics Data file and CTL file.
Related Documentation:
CRM Help Documentation: Processing Sales Data Files Using the Analytics Admin Page