Overview:
Calls records that are made on weekends are not being included on VInsights reports. This results in a discrepancy between Salesforce.com (SFDC) reporting and VInsights reports.
Root Cause:
This is working as designed. VInsights does not calculate calls that were made on the weekend. If the requirement is for VInsights to match the results of an SFDC report, the SFDC report needs to be modified to exclude calls made on the weekend as well.
Solution:
Create a new formula field on the Call object that is text call Day of The Week.
Use this formula: CASE(MOD( {!Call_Date_vod__c } - DATE(1900, 1, 6), 7), 0, "Saturday", 1, "Sunday", 2,"Monday", 3, "Tuesday", 4, "Wednesday", 5, "Thursday", 6,"Friday","").
Set this field to be read but not on the page layout. When building the SFDC report, use the filters to exclude: Saturday and Sunday. The weekday calls that take place are shown.
Related Documentation:
CRM Help: Viewing Reports in the Analytics Tab