Overview:
The Active Workflows View will only display workflows that a user is directly assigned as a participant or Workflow Owner at the time the workflow is initiated.
Root Cause:
Reasons why workflow will not appear in Active Workflow View:
Role-based assignment
Users that are granted workflow participation via role do not see these workflows listed in the Active Workflow view.
Re-assigned after workflow initiation
If a Workflow Owner or participant is reassigned after initiation, they will not see the workflow in the Active workflow view.
Solution:
As a workaround, you can create a custom view and apply a filter for Workflow Owner or Task Owner
Note: This does not apply to legacy workflow.
Related Documentation:
Vault Help Documentation: Active Workflows