Overview:
Two records are merged in Veeva Network, but the loser record does not get deleted in CRM by the Integration Process. Its Customer Master Status remains Valid even though it has the merged_into Record State in Veeva Network.
Root Cause:
The Veeva Network Target Subscription is set to only export Valid and Under Review records:
Solution:
If the Target Subscription only exports Valid and Under Review records, it skips loser records that are merged_into Record States. Therefore, the loser record does not get listed in the Target Export files and it is ignored by the Integration Process.
The System Admin user needs to set the Record State setting to All and the Full Data Extract setting to Full, to be sure all loser records are included in the next Target Subscription job. Once the job runs, the System Admin can switch the subscription back to Delta if needed.
Related Documentation:
Network Help Documentation: Add a target subscription