Overview:
When an Alert record is created, the Push_Notify_APNS_Status_vod__c field value stays at Queued. The Last_Push_Notify_APNS_Datetime_vod__c field remains unchanged as well on the Alert_vod__c record after running the Mobile CRM Administration job. This is despite the push notifications arriving successfully for iPhone.
Root Cause:
Read Field-level Security (FLS) is not provided for the Link_Reference_Long_vod__c field of the Alert_vod__c object. If the integration user does not have FLS to this field, the Push_Notify_APNS_Status_vod__c field never changes to Processed (despite being successfully pushed).
Solution:
The integration user needs to have Read FLS for the Link_Reference_Long_vod__c field.
Related Documentation:
CRM Help Documentation: Managing Push Notifications