Problem:
Approved Email Administration sync displays the error:
Error: could not upsert Approved Content. The error reported was: (ENTITY_SAVE_ERROR) INVALID_DATA: Invalid value(s) [Product] specified for parameter [product__vr.vexternal_id__v] : Object field value(s) do not resolve to a valid active.
Root Cause:
The vault is missing a Product_v record that matches the value of the External ID of the Promomats or Medcomms Product.
Solution:
Navigate to the product on the document record in question in the Promomats or Medcomms Vault.
- Note the value of the External ID field. In Vault CRM, the matching is case sensitive.
In Vault CRM, navigate to the matching product record (or create one) and record the value of the Vault product's external ID into the vexternal_id__v field on the product record.
Once updated, navigate back to the Approved Email Administration page and initiate an Incremental Sync.
Related Documentation:
Vault CRM Help Documentation: Configuring Approved Email Admins and Integration Users