Overview:
Upon running a Push to CRM, the following error occurs:
MC_Cycle_Plan_vod__c Failed to upsert. Reason: TRANSFER_REQUIRES_READ:The new owner must have read permission:--
The territory of the affected data may not be in relation with the territory the push to crm job was started from, the territories may not be in the same branch.
Root Cause:
The cause of the error is due to misconfiguration in Veeva CRM, the end-user who would become the owner of the MCCP does not have the necessary MCCP related object, field, record permissions or access.
The behaviour of the Push to CRM is expected. Any active, Published and non-end dated MC Cycle Plan that needs an owner change will get included in the push to update the owners. This happens regardless of whether that push was initiated from a single territory or at the Veeva CRM org level.
The owner update logic is as follows:
- If the MCCP owner is already defined as only valid user in that territory (as defined by Roster Member Territories) in CRM, there would be no update.
- If the MCCP owner is not equal to the only valid user in that territory (as defined by Roster Member Territories) in CRM, then the owner will be updated to that user.
- If there are more than one users on that territory, the MCCP owner will be set as the integration admin if it isn't already set as the integration admin.
Solution:
Provide the end user the necessary Object, Field and Record permissions and access.
Related Documentation:
Align Help Documentation:
CRM Help Documentation: