Overview:
Upon running an Import from CRM job the following the Account error file contains the following error(s):
Failed to upsert. Reason: OPERATION_NOT_ALLOWED: Another resource already exists with [external_id__aln=EXTERNALID]
Root Cause:
As the error suggests, the issue is caused by the External ID value already existing in Align for an Account record. This Account may be inactive.
Reasons why this scenario occurs:
- Historical Data
- The Account was deleted in CRM, an Import from CRM was run, then the Account with the same External ID was recreated in CRM
Solution:
Remove these Accounts or modify their External ID values if deletion is not an option.
Note: The Account Process Monitor record needs to be adjusted to pick up the Accounts again from CRM. Optionally a Full CRM Refresh or an adjusted Import Date Override will also retrieve these Accounts.
Related Documentation:
Align Help Documentation:
Knowledge Article: