Overview:
When creating new Inventory Monitoring, the Assortment record is not visible on the iPad while clicking on the Assortment field.
However, it is working correctly Online.
Root Cause:
The following common reasons can lead to this issue:
- The user's profile has only Master Record type and no Record type is defined as the default for the Inventory Monitoring object. When using Permission Sets, it is not possible to default a Record type.
- The user is missing Field Level Security (FLS) for the Inventory_Monitoring_Date_vod field on the Inventory Monitoring object.
- FLS is incorrectly granted for the user while Inventory Monitoring Record Types are not in use.
- The Assortment's Account_Record_Type_vod field name does not match with the Account's Record type Name.
Solution:
In order to solve the problem:
- Set a default Record type for the Inventory Monitoring object on the user's profile.
- Grant the user FLS for the Inventory_Monitoring_Date_vod field on the Inventory Monitoring object.
- If Inventory Monitoring Record Types are not in use, make sure to remove FLS from the Inventory_Monitoring_Record_Type_vod field on the Assortment object.
- Assortment's Account_Record_Type_vod field name needs to match with the Account's Record type Name (if Assortment_vod.Account_Record_Type_vod is not empty).
Related Documentation:
CRM Help Documentation: Inventory Monitoring Assortments