Overview:
After loading a distribution package to a Multichannel Slide in Vault, an error appears after the user tries to Approve the document: Exception occurred while delegating call of extractZipToRemote() to Edgecast api with arguments: path: <path>.
Root Cause:
There is a problem with the Distribution Package uploaded to Vault for this slide. The issue could be:
- There is a corrupt or 0 KB file in the distribution package. This file can be in the JS, CSS, or other folders contained in the distribution package.
- There is a file with invalid characters in the file name.
Solution:
Determine the root cause of the error by systematically eliminating folders/files in the Distribution Package one by one and uploading to Vault until the file no longer causes the error. Once the file causing the error is isolated, replace the file with a valid file and repackage the Distribution File.
Related Documentation:
CRM Help Documentation: Packaging Custom CLM Content