Overview:
When completing the Document Change Control workflow, an error occurs: Can't Add Document. Document Already Exists in Content Set [SDK_ERROR: INVALID_DATA]. The error prevents users from completing the workflow and moving the Document Change Control to Approved status. Why does this error occur?
Root Cause:
One possible reason is that multiple versions of a document are added to the Training Requirement record.
When the document moves into Approved status, the Entry Action of the document lifecycle creates a Training Requirement Impact Assessment. However, there are multiple versions of a document in the training material of the training requirement, but admins shouldn't add multiple versions of a document in a training requirement, hence this error occurs.
Solution:
Admins need to remove the multiple versions and leave only one version of the document in the training material.
Related Documentation:
Vault Help: Training Material limitations
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