Overview:
A 404 error occurs when users click on the links in any emails from Vault to open a report, a document, or a record using their SSO accounts.
URL:
Root Cause:
The error is caused by an invalid Identify Provider Login URL configured in Vault. The & character, between aspx and RelayState, should be a ? character according to the HTTP specification. The first query parameter must be designated with a ? and all subsequent query parameters are designated with a &.
Solution:
An admin needs to do the following:
- Navigate to Admin --> Settings --> SAML Profiles --> [SAML Profiles].
-
For the Identity Provider Login URL field, change & to ? between sso and RelayState.
The correct URL should be:
https://adfs.domain.com/adfs/ls/IdpInitiatedSignOn.aspx?RelayState={{#url_encode}}RPID={{#url_encode}}http://customer.vault.com{{/url_encode}}&RelayState={{{relay_state}}}{{/url_encode}}
Related Documentation:
Vault Help Documentation: About Deep-Linking (Single Sign-on Profiles)