Overview:
When a user is creating a Medical Inquiry Fulfillment Response in iRep, an incorrect Page Layout is being displayed. This Page Layout also lacks the Reassign_vod checkbox field as well as the Assign_To_User_vod field.
Root Cause:
The record type Medical_Inquiry_Fulfillment_vod on the Call object is automatically assigned to the Specialty Layout page layout. There is a Medical_Inquiry_Fulfillment_vod Page Layout that should be used instead. The section of this page layout titled Medical Inquiry Fulfillment lists the Reassign_vod and Assign_To_User_vod fields if the are on the Page Layout for the Medical Inquiry Fulfillment Response object.
Solution:
For Medical Inquiry Fulfillment Response to use the correct layout and display the Reassign_vod and Assign_To_User_vod fields the following steps need to be completed:
- Log into the CRM org as an Administrator.
- Navigate to: Setup --> App Setup --> Create --> Objects.
- Drill into the Call Object.
- Scroll down to the Page Layout-related list and click Page Layout Assignment.
- Click Next until the Medical_Inquiry_Fulfillment_vod Record Type appears.
- Click Edit Assignments.
- Highlight the Specialty Layout and use the picklist titled Page Layout To Use to select the Medical_Inquiry_Fulfillment_vod Page Layout.
- Click Save.
- Navigate to:Setup --> App Setup --> Create --> Objects.
- Drill into the Medical Inquiry Fulfillment Response object
- Scroll down to the Page Layout-related list and click Page Layout Assignment.
- Open the layout being used for the Medical_Inquiry_Fulfillment_Response Record Type.
- Add the fields Assign_To_User_vod and Reassign_vod to the Information section of the Page Layout.
- Click Save.
- Clear Veeva Cache.
After completing these steps, the correct page layout appears. As long as the end-user has Field Level Security (FLS), the Assign_To_User_vod and Reassign_vod fields display as well.
Related Documentation:
CRM Help Documentation: My Setup Products Alignment of Promotional Items and BRCs by User
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