Overview:
The Medical Inquiry Fulfillment Tab is not displaying results online.
Root Cause:
This can be caused by a lack of Field Level Security (FLS) or missing Record Access.
Solution:
The following query is run on the Medical Inquiry Fulfillment Tab Online:
SELECT Product_vod__c,Account_vod__c,Status_vod__c,Delivery_Method_vod__c,Initiated_By_vod__c,Id,Name,Initiated_Datetime_vod__c,Account_vod__r.Id,Account_vod__r.Name FROM Medical_Inquiry_Fulfillment_vod__c where Status_vod__c != 'Completed_vod' and Account_vod__r.Id != null and OwnerId = 'xxxxxxxx'
The following should be investigated:
- All fields need to be checked for proper Field Level Security.
- Status_vod__c and OwnerId needs to be checked for accuracy.
- Check that the user has Record Access to the Account filled in the Account_vod__r.Id field.
Related Documentation:
CRM Help Documentation: Medical Inquiry Fulfillment