Overview:
A Vault user does not receive a password reset email when attempting to reset their user password in Vault.
Root Cause:
A Vault user not receiving the password reset email can have multiple root causes.
Solution:
The following are suggestions to resolve this issue for the affected user:
- Check to make sure that the email address on the user record is correct (also check that there are no trailing spaces or incorrect characters)
- Check if the user is entering their username or email address on the reset password page.
NOTE: The user should type a User Name on the forgot your password page only. - Check the Email Log under Admin > Logs to make sure the password reset email was sent to the user by Vault. Also check the event_type and details field values in the CSV file report after exporting for more details about the email's sending.
- Check the Email Suppression List to make sure the user's email address has not been added to the Email Suppression List. If it has, the user's email address will need to be removed from the Suppression List for Vault to be able to deliver emails to that address.
- If the user's email address is correct, the user's email address is not on the Email Suppression List, and the Email Log shows the email being sent from Vault, take the following steps to troubleshoot why the user is not receiving the email locally:
- On the local machine, check to determine if the email is in the SPAM folder
- Work with the company IT Department to ensure that the email is not delivered to the company email server SPAM folder by accident
- Work with the company local IT Department to add vault-emails@veeva.com to the company email white list
- If the company uses Microsoft Outlook, have local IT confirm if vault-emails@veeva.com needs to be added to the Safe Senders List at the user level.
If none of the suggested solutions resolve this issue, please open a ticket with Veeva Support.
Related Documentation:
Microsoft Help Documentation: Add recipients of my email to the Safe Senders List
Vault Help Documentation: Email Log
Vault Help Documentation: Changing Your Profile, Password & Notifications