Overview:
An Account cannot be assigned to a Territory through Territory rules, even if the Account meets every rule criteria.
Root Cause:
The IsExcludedFromRealign field is set as True on the Account which excludes the Account from Territory assignment rules.
Solution:
The IsExcludedFromRealign field needs to be set to False on the Account record.
Related Documentation:
- CRM Help Documentation: Territory Management
- CRM Help Article: Removing Acounts from Territories