Overview:
A Manager in iRep clicks on the Coaching Report tab and cannot find any coaching reports available to create for Sales Reps. The Manager can see available reports from the Advanced Coaching Reports tab Online.
Root Cause:
The user is missing CRUD (Create, Read, Update, and Delete) access to either Survey_Target_vod or Question_Responses_vod.
When the user clicks the + button on the new Coaching Tab in iRep, only Surveys of type Coaching_Report_vod that meet the following criteria are displayed:
- The Current Date is between the Start and End dates of the Coaching Report
- The user has access to the Coaching_Report_vod Record Type on both Survey_vod and Survey_Target_vod
- The user has full CRUD access to Survey_Target_vod
- The user has full CRUD access to Question_Responses_vod
For Online, the user can see Coaching Reports regardless of Survey_Target_vod and Question_Responses_vod CRUD.
Solution:
Be sure the user has full CRUD access to Survey_Target_vod and Question_Responses_vod. If the user is missing even Delete access, no Coaching Reports are seen available Offline.
To provide CRUD access to Survey_Target_vod and Question_Responses_vod,
- Navigate to: Setup --> Manage Users --> Profiles.
- Drill into the correct Profile.
- Click Edit.
- Grant Create, Read, Edit and Delete access to the Survey Target and Question Responses objects from the Custom Object Permissions section.
- Clear the Veeva Cache.
Related Documentation:
CRM Help Documentation: Advanced Coaching Reports