Overview:
The user lookup field in the Advanced Coaching Report is not fully visible.
Example:
A manager has 10 subordinates, but can only see less than 10 search results. This means not all the subordinates are displayed.
Root Cause:
The Profile Filtering is enabled in this Org and View All Profiles Administrative Permission is not enabled for the user.
If Profile Filtering is disabled, users can see all profile names regardless of which permissions they have.
If Profile Filtering is enabled, it is possible to restrict who sees profile information to the users who require access for their job roles.
With Profile Filtering enabled, some users can see profile names in specific scenarios.
Profile names are exposed when users with permissions to perform these tasks take these actions:
- View the Setup Audit Trail to determine if users have the View Setup and Configuration permission.
- Create a tab or record type with a wizard step that includes the assignment of tabs and record types to profiles.
- Set up delegated admins who look up profiles as necessary to identify assignable profiles.
- Administer Salesforce as a delegated external user admin.
- Administer Salesforce as a delegated admin to view and assign profiles of the delegated group.
Solution:
Solution 1: Disable Profile Filtering in User Management Settings.
Solution 2: Grant View All and Modify All user permission to the user profile.
Related Documentation:
Salesforce Help Documentation: Limit Profile Details to Required Users