Problem:
The necessary visibility has been granted via MySetup and Record Sharing, however when creating a new Order or Inventory Monitoring Record, the Line is not visible Offline. Online it works and the VMOCs are correct.
Root Cause:
The affected user has no access to the Parent Product of the affected Order/Inventory Product.
Solution:
Grant Access to the Parent Product as well.
Related Documentation:
CRM Help Documentation: Configuring Order Management