Overview:
The user has Delete permission on the Order_vod object. The Delete button is visible Online for Orders in Saved status. However, the Delete button is not available Offline for the same Saved Order.
Root Cause:
Previously, the Delete button appeared and the user could delete Offline created Orders only until they synced up. This behavior changed.
Since introducing Autosync, all records for all objects sync automatically. This is similar to what formerly is called Autosend on Submit. This is special handling that Veeva does for Orders.
Solution:
This is working as designed. Consider using the Void Order functionality.
Related Documentation:
CRM Help Documentation:
CRM Knowledge Article: