Overview:
No system emails are delivered to the users' email addresses, even when this would be expected. Example: No system emails sent after an email address modification or a password reset.
Root Cause:
The Email Deliverability settings applied are not allowing users to receive automatic system emails.
Solution:
Email Deliverability settings need to be amended as follows:
- Navigate to Setup --> Administer --> Email Administration --> Deliverability.
- See that the Access level setting at the top of the page in the Access to Send Email (All Email Services) section is set to No access.
- Change this value to System email only or All email in the picklist.
- Click Save.
Once the No access setting is changed, users start receiving automatic system emails.
Different setting values control Email Deliverability as follows:
- The No access setting prevents all outbound emails to and from users.
- The System email only setting allows only automatically generated emails, such as new user and password reset emails.
- The All email setting allows all types of outbound email.
Related Documentation:
Salesforce Documentation: Guidelines for Configuring Deliverability Settings for Emails