Overview:
A user enables the Territory_Link_on_Account_vod Veeva Setting, but the link does not display any Territories in CRM iPad.
Root Cause:
The relevant AccountShare records are not downloaded to CRM iPad.
Solution:
Modify the VMobile Object Configurations (VMOC) of AccountShare and be sure the relevant AccountShare records are downloaded.
Related Documentation:
CRM Help Documentation: Account Details - CRM for iPad and iPhone