Overview:
Issues occur when approving documents using the SSO feature. When approving a document, a message occurs: You must validate your eSignature credentials with your corporate single sign-on service to complete this action.
Root Cause:
Some browsers prevent users from completing eSignatures with their SAML Identity Providers through an iFrame.
Solution:
An admin can configure the eSignature flow to complete through a pop-up by selecting the Authenticate SAML eSignatures in a pop-up window rather than an iFrame checkbox.
- Go to Admin --> Settings --> SAML Profiles.
- Click the SAML Profile settings.
- Select Authenticate SAML eSignatures in a pop-up window rather than an iFrame. checkbox.
Related Documentation:
- Vault Help Documentation: Vault Help