Overview:
A user is assigned to multiple Territories. However, during the CRM New Account Wizard process, the Territory field is Read-only and cannot be selected.
Root Cause:
The Enable User Assigned Territory in Veeva Settings is not enabled.
Solution:
To enable this option:
- Navigate to: Setup --> Develop --> Custom Settings.
- Select Manage Settings next to Veeva Setting.
- Select Edit.
- Check the checkbox of Enable User Assigned Territory.
- Select Save.
- Clear the Veeva cache.
Related Documentation:
CRM Help Documentation: Territory Assignment