Overview:
Veeva Snap is a mobile application for iOS™ devices (iPad®, iPhone®, and iPod Touch®) that allows the scanning and uploading of documents to a Vault using a device’s camera. If the Vault uses Single Sign-on (SSO), Veeva Snap redirects to the identity provider’s login page.
Veeva Snap is configured in an OAuth 2.0 / OpenID Connect Profile (Navigate to: Admin --> Settings --> OAuth 2.0 / OpenID Connect Profiles).

When logging into Snap with an SSO account, an Error: Invalid authorization configuration occurs.

Root Cause:
The OAuth 2.0 / OpenID Connect Profile where Veeva Snap is configured is not selected in the SSO Security Policy that the user account uses.

Solution:
The Domain Admin needs to select the OAuth 2.0 / OpenID Connect Profile where the Veeva Snap has been configured in the SSO Security Policy that the user account uses.
Use the following steps to do so:
- Navigate to Admin --> Settings --> Security Policies --> [Security Policy].
- Select an OAuth 2.0 / OpenID Connect Profile for the OAuth 2.0 / OpenID Connect Profile field.
Related Documentation:
- Vault Help Documentation: Vault Help
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