Overview:
Why are the Credentials of an Align Integration User Periodically Invalid in Veeva Align?
Root Cause:
Upon clicking on the Validate Credentials button in the Integrations -> Align Integrations Tab, the Align Integration User credentials are shown invalid. After resetting its password, the issue reoccurs again in a certain period of time. This may be due to its Security Policy having Password Expiration set.
The Align Integration User must be a Non-Expiring Vault Owner User (Full User). This user must not be locked out, has to be active, has to have valid credentials - Username and Password.
Solution:
Creating or modifying Security Policies requires a Vault Owner Profile and Domain Admin access.
In order to manage Security Policies, follow these steps:
- Navigate to Admin -> Settings.
- Under the Domain Settings section, click on Security Policies.
- It is recommended to create a new Security Policy with no Password Expiration.
- Assign this Security Profile to the Align Integration User.
The screenshot shows an example, the other fields can be adjusted on demand.
Related Documentation:
Align Help Documentation:
Vault Help Documentation:
Knowledge Article: