Overview:
When creating a Medical Inquiry record from the More Actions menu of a Call Report on CRM iPad, an error appears: This action is no longer available because there is an update. Please refresh the page.
Root Cause:
The default status_vod__c value for the Medical Inquiry record type is set to Submitted_vod. Editing is not allowed on submitted records, thus going into the invalid action flow.
Solution:
Remove the default Submitted_vod selection from the Medical Inquiry record type on the Medical Inquiry object.
- Navigate to Medical Inquiry within Object manager --> Record Type --> Medical Inquiry
- Click the Edit button next to Status
- Click the Default dropdown and change the value to --None--
Related Documentation:
Salesforce Support: Default Field Value Considerations