Overview:
The Product picklist becomes None in the Product Discussions section when editing a call in CRM Online. However, it remains when the user cancels the editing.
Root Cause:
The user has no Field-Level Security (FLS) to Detail_Group_vod__c field of Call Discussion.
Solution:
Grant the user FLS to Detail_Group_vod__c field of Call Discussion.
After that, the user also needs to open the Call record, select relevant products again on the picklists, and then save the Call record to make the change effective.
Please refer to this guide for more information: Field-Level Security
Related Documentation:
CRM Help Documentation: Capturing Product Discussions on the Call Report