Overview:
The user gets an error stating that there are documents that reference the affected Milestone in Vault. When attempting to determine the affected documents, the user is unable to find them using Vault Reporting.
Root Cause:
The documents that reference the affected Milestone have been archived.
Solution:
To resolve this issue, the user will need to unarchive the impacted documents so that the milestones are removed and then delete the milestones and manually archive the documents.
Alternatively, if the business process allows it, the user could deactivate the milestone instead.
Note: If the Study is on a reused document for a Study that was archived in the past, this behavior can also occur. When Vault takes a snapshot of a document, it does not remove values in the Milestones field for other studies that are not archived.
Related Documentation:
Vault Milestone Documentation: Archiving Documents