Overview:
The User has all the required configurations in this guide: Deploying MyInsights Pages to Veeva CRM.
But the user still cannot access MyInsights Studio and the Page is keep loading in CRM.
Root Cause:
The Restrict Access to Custom Settings is enabled and the user has no access to Veeva-delivered custom settings.
Salesforce documentation: Protection and Privacy Options for Custom Settings
If the Restrict Access to Custom Settings schema setting is enabled, all users require access to the VeevaSettingsService Apex class in order to access Veeva-delivered custom settings in Salesforce.
Solution:
Add the required access to the VeevaSettingsService Apex class in order to access Veeva-delivered custom settings in Salesforce.
Salesforce documentation:
Related Documentation:
CRM Help Documentation: Veeva Custom Settings