Overview:
The Account Plan Dashboard does not display in CRM Online. It shows a blank page as shown below:
Root Cause:
Here are the possible reasons for this problem:
- The user is missing Field Level Security (FLS) read permission on the Account_Plan_vod__c and Account_Tactic_vod__c fields on the Call Objective object.
- The user does not have access to Veeva-delivered Custom Settings like (Veeva Settings, Multichannel Settings, Territory Settings) etc.)
Note: VeevaSettingsService automatically provides access to all Veeva-delivered
custom settings, but will not if the user has any custom settings
definitions granted through profile or permission.
Solution:
- Grant FLS read permission to the user on the Account_Plan_vod__c and Account_Tactic_vod__c fields on the Call Objective object.
- Admins can give individual users access to all Veeva Custom Settings through either of these options:
- Ensure the user has access to all Veeva-delivered custom settings definitions through profile or permission set
- Grant the View All Custom Settings system permission through their profile
Related Documentation:
CRM Help Documentation: