Overview:
MyInsights content cannot be deployed from MyInsights Studio to Veeva CRM.
A red icon of an exclamation mark appears under Deployment Status when attempting to deploy:
Root Cause:
Some of the following requirements are not met:
- There is a Null Pointer Exception related to the External_Id_vod__c field on the HTML_Report_vod__c object. This can happen if the External_Id_vod__c field on the HTML_Report_vod__c object is marked required in the Org. This field is not a required field in MyInsights Studio.
- The MyInsights Content being published is of a type where there can be only one published MyInsights record at a time. Account Profile Overrides, KOL Profiles, and the home page Territory Insights Default MyInsights Landing Screen are limited in this way. If content, that is limited in this way for a specific User Profile/Object Record Type, is published in MyInsights Studio, and an attempt to publish other content of the same User Profile and Object Record Type combination is made, the Deployment fails.
Solution:
- Verify that the External_Id_vod__c field on the HTML_Report_vod__c object is not set to Required in the Org.
- Verify that the MyInsights Content being published is not of a type limited to one at a time for Record Types and/or User Profiles.
- Verify that no other MyInsights Content of that combination is published to the Org.
Related Documentation:
CRM Help Documentation: