Overview:
An error occurs: An error happened while querying Vault. Email will be processed again when the Scheduler job runs next time. A Sent_Email_vod record stays in the Saved_vod status while the field Failure_Msg_vod contains the value.
Root Cause:
The user in the Vault Login Credential Management section of the Approved Email Administrator tab is not an Admin or Owner in the Vault to which the Org is connected. The error occurs because CRM is unable to communicate with Vault while attempting to send the email.
Solution:
- Log into the CRM Org as an Administrator.
- Navigate to All Tabs (+) and drill into Approved Email Administrator.
- Scroll down to Vault Login Credential Management.
- The user listed here needs to be a Vault Administrator or Vault Owner in the Vault listed.
- Either update the Vault Login Credential Management with a user that is a Vault Administrator or, be sure this user is an Administrator in Vault.
- Clear the Cache.
After performing these steps, the Approved Email Job Process can be be run to immediately send these failed emails. Or, if the job is scheduled to run automatically, these emails are sent the next time it runs.
Related Documentation:
CRM Help Documentation: Integrating CRM and Vault for Approved Email