Problem:
Approved Email templates will not update in CRM despite the Approved Email Administration screen reporting a successful sync. The Successful Rows column will also report the same number of successes on each sync. Opening the Success log will also show the same documents being synced on each successive sync.
Root Cause:
This issue is caused by partial configuration of the Email Builder feature by granting the CRM integration user access to some of the required Email Builder fields.
Solution:
Complete configuration of the Email Builder feature as indicated in the Help article.
If admin's do not wish to configure the Email Builder feature, they must revoke the integration user's access to the following fields and objects:
| Object | Remove Access to |
| Approved_Document_vod |
|
| Sent_Email_vod |
|
| Email_Builder_vod | All OLS/FLS |
| Email_Builder_Cell_vod | All OLS/FLS |
| Email_Builder_Rule_vod | All OLS/FLS |
| Email_Builder_Rule_Cell_vod | All OLS/FLS |
| Sent_Email_Builder_Cell_vod | All OLS/FLS |
Once access has been revoked, perform a Force Full Refresh in the Approved Email Administration screen.
Related Documentation:
CRM Help Documentation: Email Builder