Overview:
The Add Calendar Entry does not appear in My Schedule.
Root Cause:
The problem occurs if:
- Edit Events Salesforce.com (SFDC) permission is missing or
- Mobile_Id_vod__c Field Level Security (FLS) is missing for the Event SFDC Object.
Solution:
To enable Profile Permission:
- Navigate to: Setup --> Manage Users --> Profiles.
- Select the Profile Name that is affected.
- Select Edit.
- Check the permission for Edit Events under General User Permission.
- Select Save.
- Scroll to Field Level Security --> Standard Field-Level Security.
- Click on View next Event.
- Check FLS for the Mobile ID field.
- Select Save.
- Clear the Veeva cache.
Related Documentation:
CRM Help Documentation: Integrated Scheduling